transfer stats wrong?

Matt McCutchen matt at
Mon Mar 31 04:12:43 GMT 2008

On Sun, 2008-03-30 at 22:34 -0500, Dan Letkeman wrote:
> I have a set of files on my laptop running xp.  I'm using
> cwRsync_2.0.10 and syncing to a Netware Server.  Everything appears to
> be working fine, but the stats don't look right.  When I run the sync
> for the first time it says this:
> Number of files: 2429
> Number of files transferred: 2119
> Total file size: 350713189 bytes
> Total transferred file size: 350713189 bytes
> Literal data: 0 bytes
> Matched data: 350713189 bytes
> File list size: 53362
> File list generation time: 0.555 seconds
> File list transfer time: 0.000 seconds
> Total bytes sent: 839730
> Total bytes received: 1094786
> sent 839730 bytes  received 1094786 bytes  19639.76 bytes/sec
> total size is 350713189  speedup is 181.29
> And when I run it a second time without changing any files it says
> exactly the same thing.  Why is it still transferring 2119 files

Probably differences in mtime are preventing rsync's "quick check" from
skipping transfers of unmodified files.  To confirm this, pass -i and
see if you get itemize codes like ">f..t......".  Then, pass -t if you
aren't doing so already, and try --modify-window=1 in case mtimes on the
destination filesystem have two-second granularity.  If that doesn't fix
the problem, I'll give you some more things to try.

> and
> why does it say that it received 1094786 bytes?

Delta-transferring 350MB of files that turn out to be unmodified could
reasonably involve receiving that much data.


More information about the rsync mailing list