Rsync failures when things are going too fast ?

Pierre Chatelier ktd at
Tue Mar 25 09:24:48 GMT 2008


I am sorry I can't make a good bug report for that, but I had an  
experiment that I would like to share - because I think it might  
point a bug, even if I could solve the problem.

I usually use rsync to make backups to an external drive (through  
FireWire 800). It works very well (even better with 3.0.0 release).
Yesterday, I changed the destination drive of the backup to the hard  
disk of another Macintosh of my own, booted in "target" mode, that  
means that it does not boot the system, but makes the disk behave  
like a regular external hard drive.
And while processing the backup (rsync  -A -X -H -E --sparse -- 
archive --verbose --progress --delete --delete-excluded --delete- 
delay --human-readable), I had several errors of type :
rsync: failed to set times
mkdir (...) failed: Invalid argument (22)
mkstemp (...) failed: Invalid argument (22)

I saw absolutely no reason why it would fail. I tried to play with -- 
iconv, --protect-args, but it had no incidence at all. Indeed, there  
were no reason for such a failure. Both disks (source and  
destination) are in HFS+, I use no rsync daemon but a simple rsync   
command... and it used to work well.

The only difference I could see was:
	-backup work on my external hard-drive (5400rpm) through FW800
	-backup does not work on another drive (7200rpm) through FW800
The only difference being the speed of the two disks, I tried to play  
with --bwlimit, but it did not work.
Eventually, I tried to backup trough FireWire 400 instead... and it  
worked !

I cannot make any clever diagnostic, I do not know rsync well enough.  
Is there any reason for which rsync could fail if the target drive is  
very efficient ?

I only tried with rsync 3.0.0, compiled on my PPC machine with MacOS  
10.4 (gcc version 4.0.1 (Apple Computer, Inc. build 5367))


Pierre Chatelier

More information about the rsync mailing list