Suggestions for basic rsync configuration

Stuart Halliday StuartH at
Fri Mar 14 14:15:22 GMT 2008

> Thanks for your response, I think that I am on my way of getting stuff
> configured here. I still have a couple of questions though. I am also
> using linux with rsync!!! I want to clear up the usage of the 
> following command:
> rsync --progress -zav -e ssh /random/file-or-directory
> <remote-server-ip-address>:/random/file-or-directory
> Does that command mean that I connecting to the remote server and
> coping the desired folder and files,

Yes. Well the contents of the directory not the directory and its contents
due to the missing trailing '/'.

> rsync --progress -zav -e ssh
> <remote-server-ip-address>:/random/file-or-directory
> /random/file-or-directory

Then the opposite happens. Remote to local files are copied. But remember
any extra files in the destination will not be deleted. You need to use
--delete for that to happen.

> I have set up the rysnc daemon successfully on the remote server (I
> think),
> which prompts for the password when I connect. I get the following
> error
> when I run rsync daemon: 
> # rsync daemon
> rsync: link_stat "/directory-path/daemon" failed: No such file or
> directory
> (2)
> rsync error: some files could not be transferred (code 23) at
> main.c(977)
> [sender=2.6.9]
> Is there anything that I still have to configure for the rsync daemon?

read this site:

> I
> also get the following error when I run the following command:
> # rsync --progress -zav -e ssh /random/file-or-directory
> <remote-server-ip-address>:/random/file-or-directory
> Password: 
> building file list ... 
> 1 file to consider
> ERROR: cannot overwrite non-directory with a directory
> rsync error: errors selecting input/output files, dirs (code 3) at
> main.c(488) [receiver=2.6.8]
> rsync: connection unexpectedly closed (8 bytes received so far)
> [sender]
> rsync error: error in rsync protocol data stream (code 12) at io.c(453)
> [sender=2.6.9]

> Is this an error from a lack of rights to the files and folders that I
> want
> to copy? I might have misconfigured my config, I can post it if you
> want.

Forget ssh until you've got it working as plain vanilla Rsync.

Like I said in my 1st posting. Get a working daemon and then list a rsync
folder using a Rsync list command.

Don't do anything else until you've got that working.
You're trying to skip ahead me thinks. :-)

Stuart Halliday

This email is the property of ECS Technology Ltd.
This company is registered in Scotland with company number 212513. 
VAT registered GB 761 7456 12

More information about the rsync mailing list