DO NOT REPLY [Bug 5318] New: Rsync assertion in check_prior() when using --append

samba-bugs at samba-bugs at
Tue Mar 11 17:24:51 GMT 2008

           Summary: Rsync assertion in check_prior() when using --append
           Product: rsync
           Version: 3.0.0
          Platform: Other
        OS/Version: FreeBSD
            Status: NEW
          Severity: normal
          Priority: P3
         Component: core
        AssignedTo: wayned at
        ReportedBy: stef at
         QAContact: rsync-qa at

Seems like rsync 3.0.0 daemon process will assert when using --append under
certain circumstances. 

 * This worked in 2.9.6. 
 * Removing the --append option avoids the assertion.
 * Tried to make a test case using less rsync options, but the 
   problem becomes harder for me to reproduce.


FreeBSD 6.2-RELEASE-p9 FreeBSD 6.2-RELEASE-p9 #3: Mon Dec 10
21:38:01 UTC 2007     sam at  i386


Assertion failed: (CVAL(node->data, 0) != 0), function check_prior, file
hlink.c, line 256.

SERVER CONFIG (running with --daemon):

syslog facility = daemon
hosts allow =
log file = /tmp/rsync.log

path = /data/d1/.store
use chroot = yes
read only = false
write only = true
uid = root 
gid = wheel


/usr/local/bin/rsync -aREHx --inplace --links --ignore-errors --delete
--delete-excluded --delete-during --exclude-from - --stats --progress
/data/d2/ m3i::d1/


2008/03/11 16:48:08 [16408] connect from (
2008/03/11 16:48:08 [16408] No match for refuse-options string "iconv"
2008/03/11 16:48:08 [16408] rsync to d1/ from
2008/03/11 16:48:08 [16408] receiving file list

Configure bugmail:
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the rsync mailing list