DO NOT REPLY [Bug 5520] New: Rsync cannot copy to a vfat partition on kernel 2.6.25+

samba-bugs at samba-bugs at
Wed Jun 4 11:11:17 GMT 2008

           Summary: Rsync cannot copy to a vfat partition on kernel 2.6.25+
           Product: rsync
           Version: 3.0.3
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P3
         Component: core
        AssignedTo: wayned at
        ReportedBy: piskozub at
         QAContact: rsync-qa at

This was reported by me on the RedHat Bugzilla (URL given) and reclassified as
a kernel bug. However, this seems to be caused by a conscious decision of the
vfat Linux kernel developers and therefore may be easier to solve from the
rsync end.

In a nutshell: Rsync cannot now copy to a vfat partition even if the user is
root (yes!). This is due to new and more strict vfat operations security model
adopted in the kernel. When rsync tries to mkstemp it gets a "not permitted"

This bug was discussed on LKML (the best URL is with n conclusions
so far. However it is clear that:

1) Kernel 2.6.25 (and newer) does not let "allows only acceptable chmod(), and
if not acceptable, it returns -EPERM. Old one allows even if it can't store the
disk inode."

2) As Hirofumi Ogawa explained to me in an email: 
"rsync will try to set permission to 0700 or something. But, FAT can't
store almost permissions to storage, because FAT doesn't have permission
field on disk inode (FAT have permission field on only memory
inode). So, chmod() returns -EPERM."

3) It is not clear how and whether at all it will be solved in the kernel
because as Pavel Machek put it: "So we have choice between security hole and

The question is: Can this be solved from the rsync end?

Configure bugmail:
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the rsync mailing list