directory with space

Matt McCutchen matt at
Wed Jul 30 13:57:20 GMT 2008

On Wed, 2008-07-30 at 12:43 +0530, Shashi Kanth Boddula wrote:
> I am using the bellow version
> rsync  version 2.6.9  protocol version 29
> My directory looks like bellow
> $ls /data/Knowledge\ Center/

(Note: The backslash here is for the benefit of the shell's word
splitting.  The directory name doesn't contain the backslash.)

> I have tried in multiple ways in rsyncd.conf file, bit still i am
> receiving @chdir failed error.

A similar module works for me with rsync 2.6.9 if I write the path with
no backslashes or quoting, like this:

path = /data/Knowledge Center

Make sure you've tried that syntax with the correct Center/Centre
spelling (you used Centre in your other message).  If that still doesn't
work, please run the daemon under strace to confirm the path it is
trying to chdir to.

>  From the logs, i observed bellow lines
>  rsync: chdir "/data/Knowledge Center" failed : No such file or
> directory (2)
> [...]

When rsync fails to enter the module, it prints the directory it is
trying to enter with no backslashes or quoting.  If rsync failed to
enter the directory you "ls"-ed above, the error would be:

rsync: chdir /data/Knowledge Center failed : No such file or directory (2)

That wasn't among the errors you pasted, so I imagine you just haven't
tried the right syntax yet.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
Url :

More information about the rsync mailing list