rsync: connection unexpectedly closed (0 bytes received so far) [receiver]

Matt McCutchen matt at
Sat Feb 16 04:00:51 GMT 2008

On Fri, 2008-02-15 at 19:28 -0600, chuang liu wrote:
> I am trying to transfer a file from a machine A to a machine B. I ran
> a rsync deamon on machine B at a given port. Because there is a firewall
> between these two machines, I opened the port on the firewall. Is this
> enough to get rsync work through firewall?
> When I tried the transfer, I got the following error messages.
> my command:
> rsync -a --copy-links localfile   rsync:://me@<my
> IP>:<port>/<module>/test.dat
> In the client side, the error messages are
> rsync: Unknown host
> rsync: connection unexpectedly closed (0 bytes read so far)
> rsync error: error in rsync protocol data stream (code 12) at io.c(151)

An rsync:// URL should have a single colon.  Since you used two colons,
rsync parsed the destination as the path "//me@<my
IP>:<port>/<module>/test.dat" on the daemon on host "rsync", hence the
"rsync: Unknown host" message.  Get rid of the extra colon.


More information about the rsync mailing list