Sends files when I don't think it should [SOLVED, sorta]

Tuc at T-B-O-H ml at
Tue Feb 5 07:37:48 GMT 2008

> Hi,
> 	I've got one thats really stumping me... rsync 2.6.9 from FreeBSD
> ports on both ends.
> /usr/local/tmp/rsync --dry-run -v -v -v -v -v -v -v -v -v -v -v -v --dry-run -vrlptHDgozxS  --partial --force --delete --numeric-ids --exclude='A/*' --include='*/' /usr/local/etc/machines/ rsync at A:/usr/local/etc/machines/
> 	It seems to be sending over files that I can't understand why.
> From an ls, sum, etc standpoint the files are the same.
	According to Einstein :

Insanity: doing the same thing over and over again and expecting different results.

	Well, I ran the rsync over again today, expecting the SAME results,
but alas... It gave me the expected behaviour today! I didn't change anything
in the command line. I didn't change anything on the sending server. I didn't
change anything on the receiving server.

	So how come one time it wanted to transfer over 40 files that shouldn't
have, and today it works perfectly????

		Thanks, Tuc

More information about the rsync mailing list