Odd behavior in an exclude-file

Roy F. Cabaniss rcaban at housedraco.org
Fri Dec 19 16:01:49 GMT 2008

I decided the most secure way to deal with backup/firewall issues between my 
work and home was to encrypt a portable hard drive and make it my backup.  
Lug it back and forth and sync as appropriate.  So I wrote myself a little 
rsync script which grabs all the files I think of as taking work to recreate.  
Which is given as follows:

rsync -avl --stats --progress --timeout=300 --exclude-from "/home/foo/bin/exclude.txt" /home /mnt/sdc2 
rsync -avl --stats --progress --timeout=300 --exclude-from "/home/foo/bin/exclude.txt" /etc /mnt/sdc2/beast
rsync -avl --stats --progress --timeout=300 --exclude-from "/home/foo/bin/exclude.txt" /srv /mnt/sdc2/beast

Since there are, as with any backups, files I don't want to bother backing up 
I created an exclude file and stored it in my bin.

- /home/foo/vmware
- /home/foo/.kde/share/apps/kmail/mail/spam/*
- /home/foo/.kde/share/apps/kmail/mail/.spam.directory/*
- /home/foo/.mozilla/firefox/tigy4u04.default/Cache
- /home/foo/packages
- /home/foo/.cxgames
- /home/foo/.cxoffice
- /home/foo/.beagle
- /home/foo/downloads/images

With the rsync script in the /home/foo/bin I ran the script with myself as 
root in the root directory.  Which leads to the reason for this letter.  

The exclude file appears to have worked, with one exception.   I don't have 
the vmware directory, the link to packages was not followed, the crossover 
directories are not in the backup ect.   All very good and as hoped.  The 
exception is in the very last line.  The very last line of the exclude file 
is the directory that contains iso images I downloaded for whatever reason.  
Things like my latest image for my distro and such.  I did NOT want to back 
those up since in the event of catastrophe I would simply redownload them and 
the files are rather sizeable.  Much to my surprise, the images directory was 
in the backup along with its contents.  I can assure you that the path is as 

Is there any idea why I got that one directory in the backup?

Roy F. Cabaniss
At least one attached file is my gpg signature.  
If you don't know how to open/use the file, don't worry about it.  
It is included for those who DO know and understand such things.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
Url : http://lists.samba.org/archive/rsync/attachments/20081219/64c02805/attachment.bin

More information about the rsync mailing list