Rsync via two ssh tunnels possible (standard method mentioned k times not possible?)

Roman Fiedler roman.fiedler at
Mon Dec 15 11:11:38 GMT 2008

Roman Fiedler wrote:
> Matt McCutchen wrote:
>> On Fri, 2008-12-12 at 12:56 +0100, Roman Fiedler wrote:
>>> The goal is to sync two directories using rsync without running the
>>> rsync daemon on one of the two hosts...
> The additional args caused nc to fail. Also \x00 instead of # did not
> work. But following worked:
> * Server side:
> nc -vnlp 1235 -c 'rsync --server --sender -r . src'
> * Client side
> rsync -e './' localhost:src dst
> with
> #!/bin/bash
> nc -v localhost 1235
> The just ignores any additional arguments.

Just worked in the test-case, but not with real system. With real data, 
rsync will sync some files and then terminate

rsync: writefd_unbuffered failed to write 4092 bytes: phase "unknown" 
[generator]: Broken pipe (32)
rsync error: error in rsync protocol data stream (code 12) at io.c(1099)
rsync error: received SIGUSR1 or SIGINT (code 20) at main.c(985)

More information about the rsync mailing list