Suggestions for basic rsync configuration

Peter Heiss pete.heiss at
Thu Apr 3 12:31:43 GMT 2008

Matt McCutchen-7 wrote:
> On Tue, 2008-04-01 at 03:36 -0700, Peter Heiss wrote:
>> Wayne Davison-2 wrote:
>> > 
>> > 
>> > Search for the string "admins" in the config file.  You presumably set
>> > the gid in more than one spot, such as in the module's settings.
>> > 
>> I have checked the config file and have not found any duplicates. Here is
>> my
>> config file:
>> uid = user
>> gid = users
>> read only = true
>> use chroot = true
>> transfer logging = true
>> log format = %h %o %f %l %b
>> log file = /var/log/rsyncd.log
>> hosts allow = *
>> slp refresh = 300
>> [remote]
>>         path = /rsync/backup_out
>>         comment = Verzeichnis fuer rsync
>>         auth users = root
>>         secrets file = /etc/rsyncd.secrets
>> I am also having problems again with the daemon, it is not responding to
>> repests... instead it just times out. It works fine without any problems
>> when I transfer files without the daemon. I am starting to loose myself
>> here
>> I think with the daemon thing. With everything configured on the Firewall
>> correctly, and with all ports opened, no idea what I am still missing. I
>> think I will just go without the daemon and just use the regular thing
>> without the daemon. Is there anything that you can suggest from my config
>> file? Everthing looks ok to me.
> The configuration file looks right to me.  If rsync is still trying to
> use group "admins", then either there's a really weird bug in rsync or
> it is using a different configuration file than you think.  If you
> previously ran an rsync daemon with a different configuration file, be
> sure to kill that process before starting another rsync daemon.  Then,
> to see what configuration file the daemon is opening, you could strace
> it:
> strace -f -o daemon.strace rsync --daemon
> But maybe you just want to use the rsync over ssh.
> Matt
> -- 
> To unsubscribe or change options:
> Before posting, read:

It works now with the daemon, I killed the running rsync process and then
started it again with the "--config=<config-file>" command and it works like
a charm. Thanks to all of you guys for helping me out here through a long
but finally solved post. Thanks a lot for your efforts!!!


Computers are like air conditioners. They both dont work, if you open
View this message in context:
Sent from the Samba - rsync mailing list archive at

More information about the rsync mailing list