DO NOT REPLY [Bug 4977] rsync: failed to set times on

samba-bugs at samba-bugs at
Mon Sep 17 00:16:12 GMT 2007

------- Comment #4 from hashproduct+rsync at  2007-09-16 19:16 CST -------
(In reply to comment #3)
> Well i tried your command and it worked without errors...
> But i saw also that all files were symlinks, maybe thats the reason why it
> doesnt works?

That explains it.  I bet rsync is trying to call lutimes to set the symlink
times but the kernel doesn't support it.  Since support for lutimes was added
to Linux in version 2.6.22, this could happen if you build rsync on a system
with kernel >= 2.6.22 and run the result on a system with kernel < 2.6.22.  Is
this your situation?

Symlink mtimes usually don't mean anything terribly important, so you probably
don't need to worry about the errors.  If you want them to go away, rebuild
rsync on the system that is running it and use that copy of rsync.

Configure bugmail:
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the rsync mailing list