DO NOT REPLY [Bug 4977] rsync: failed to set times on

samba-bugs at samba-bugs at
Sun Sep 16 22:10:23 GMT 2007

------- Comment #2 from hashproduct+rsync at  2007-09-16 17:10 CST -------
(In reply to comment #0)
> Hello, I'm using the backup script from
> for some time now without
> probs.
> But lately (like 2 weeks) rsync gives me errors like these:
> rsync: failed to set times on
> "/root/snapshot/home/hourly.0/var/www/localhost/htdocs/squirrelmail/plugins/ldapuserdata/doc/ldapuserdata":
> Function not implemented (38)

That means rsync issued a system call to set the times but the operating system
returned an error.  Such errors usually are not rsync's fault.  Try setting the
times of that file manually using "touch
to see if you get the same error.

> But it continues to backup... but i don't know if the backup actually worked...

Rsync considers most filesystem errors non-fatal: it reports them but continues
with the copy.  You can usually assume that all files are copied correctly
except those specifically mentioned in error messages.

> It also exits like this:
> rsync error: some files could not be transferred (code 23) at main.c(980)
> [sender=2.6.9]
> So i guess that some files aren't backupped :O

That message is just referring to the failure to set times.  If some files were
not copied, rsync would have printed additional errors about that.

Configure bugmail:
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the rsync mailing list