(CYGWIN) Rsync Stalling Upon first file transfer.

Jonathan Hurd texasjhurd at yahoo.com
Wed Sep 5 13:54:47 GMT 2007

Thanks Matt,
Ok well I tried setting the bwlimit, wasnt sure what to set it to. Tried high 800's down to 50kb\s. No Luck.
The weird thing is how this worked but a day ago perfectly fine. This is over a WAN, and this is a pretty good backbone between the two sites.

Is there some sort of cache I need to clear...?

----- Original Message ----
From: Matt McCutchen <hashproduct+rsync at gmail.com>
To: Jonathan Hurd <texasjhurd at yahoo.com>
Cc: rsync at lists.samba.org
Sent: Tuesday, September 4, 2007 1:35:07 PM
Subject: Re: (CYGWIN) Rsync Stalling Upon first file transfer.

On 9/4/07, Jonathan Hurd <texasjhurd at yahoo.com> wrote:
> Rsync will recieve the file list, and discover the files to consider, and
> then stalls out on the first actual file transfered.

This is a well-known problem caused by bugginess in the Cygwin
pipe/socket code.  It is being tracked in this rsync bug report:


As a workaround, try setting a --bwlimit as described in the bug report.

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list