rsync hangs when copying directories with --hard-links

Christian Jacobsen cljacobsen at
Tue Oct 30 19:57:44 GMT 2007


I have a bunch of directories which was generated long ago by Apple's as it  walked my entire home directory on a remote server
thinking that it is all part of my IMAP inbox (note, there are
absolutely no files amongst any of these directories). I didn't
realise I had all these hanging around until rsync failed to copy them
(ie, it hangs). This seems to only happen when using the --hard-links
option (with 3.0.0pre4, have not tried earlier).

It seems like not any old collection of directories will trigger this,
but the particular configuration I have will consistently. Also, I
have archived the directories, transferred them to a Debian box,
compiled rsync 3.0.0pre4 and observed the same thing happening.
Looking at the bug tracker, I didn't immediately see anything that
seemed to match this issue.

The rsync hangs at the same point, always, both on a Mac and on Linux.
The command is: ./rsync -vv --archive --hard-links /tmp/arch /tmp/archdest

I tried to add a generous amount of verbosity flags to the command to
try to see what is happening, but this causes rsync to bomb out very
early with a protocol error (anything above two v's causes protocol
rsync: connection unexpectedly closed (41 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at
io.c(603) [sender=3.0.0pre4]
_exit_cleanup(code=12, file=io.c, line=603): about to call exit(12)

I can supply (off list) an strace/ktrace and/or archive of the
particular directory structure (~3mb) which causes this. I don't have
much rsync debugging-fu, but if somebody is willing to point me in the
right direction I can have a look myself. I can also throw this into
the bug tracker, if that is a good thing to do.


More information about the rsync mailing list