rsync error

Stephen Zemlicka stevezemlicka at
Mon Oct 8 01:23:06 GMT 2007

I ran it again with no changes and it worked.  Any ideas why it didn't run
the few times I tried it earlier.

Additionally, this backup contains about 100GB of photos.  It seems to
backup each file every backup.  Any ideas?  If I run the -c, it doesn't
backup each file but it takes forever (over 1hr) to run.

Stephen Zemlicka
Integrated Computer Technologies
PH. 608-558-5926
E-Mail stevezemlicka at 

-----Original Message-----
From: hashproduct at [mailto:hashproduct at] On Behalf Of Matt
Sent: Sunday, October 07, 2007 2:36 PM
To: Stephen Zemlicka
Cc: rsync at
Subject: Re: rsync error

On 10/7/07, Stephen Zemlicka <stevezemlicka at> wrote:
> I'm getting the attached error suddenly.  I am using deltacopy for the
> of setup and e-mail notifications.  It is from a local disk to a USB
> I believe it's using rsync 2.6.6

> Executing: rsync.exe  -v -rlt --delete "/cygdrive/C/Documents and
Settings/User/Local Settings/Application
Express/" "localhost::Backup/Outlook Express/"

> rsync: writefd_unbuffered failed to write 4 bytes: phase "unknown"
[sender]: Connection reset by peer (104)
> rsync: read error: Connection reset by peer (104)
> rsync error: error in rsync protocol data stream (code 12) at

Something is interfering with the connection between the rsync client
and the DeltaCopy-managed daemon to which it is pushing files, even
though the daemon is on localhost.  Here are some things you could try
to get more information about what is causing the problem:

(1) Run rsync at -vvv verbosity level.
(2) Check the daemon's log file for any relevant messages.
(3) Run the rsync client directly at the command line instead of
through DeltaCopy.  Perhaps strace rsync to see exactly what happens
before the failure.


More information about the rsync mailing list