local rsync hangs with big files

Tom Hummel xiongfeng.tom at googlemail.com
Mon Nov 19 13:47:43 GMT 2007

Hello list,

for quite some time I've been using rsync on Windows successfully
syncing ~10k files each day. The rsync is that of Cygwin. The sync
is from one FAT FS to another FAT FS.

rsync --version output is this:
rsync  version 2.6.9  protocol version 29
Copyright (C) 1996-2006 by Andrew Tridgell, Wayne Davison, and others.
Capabilities: 64-bit files, socketpairs, hard links, symlinks,
batchfiles, inplace, no IPv6, 64-bit system inums, 64-bit internal inums
This is how I invoke rsync:
rsync -rltvhOx --progress --stats --whole-file --delete
--exclude=nicht_im_backup /cygdrive/t/ /cygdrive/z/backup

For testing I tried -vvv but it just hang anyway with no information.

For a few days now, rsync hangs in the middle of a transfer of big
files >400MiB -- no error message, no termination.

Strange thing is, when I run rsync with strace it completes without


More information about the rsync mailing list