Failed starting rsync daemon from a remote server(ssh)

wenjie zheng wenjie.zheng at
Thu May 10 14:23:17 GMT 2007

Has anyone tried to start a rsync daemon from a remote server?

I tried to execute the following command from a remote server A, but failed
[root at A ~]# ssh crcdev1 "su virtual -c
\"/usr/local/fenbu/replication/bin/rsync -v --daemon --bwlimit=1000
--config=/usr/local/fenbu/replication/conf/email_rsyncd.conf\" "


@ERROR: protocol startup error

the error message in the rsync log files says:
2007/05/10 09:55:54 [30320] forward name lookup for
crcdev1.excedent.usfailed: ai_family not supported
2007/05/10 09:55:54 [30320] connect from UNKNOWN (localhost)

I have no problem start the rsync daemon locally (stay on crcdev1, run 'su
virtual -c "/usr/local/fenbu/replication/bin/rsync -v --daemon
--bwlimit=1000 --config=/usr/local/fenbu/replication/conf/email_rsyncd.conf"
And the rsync I use is
[root at crcdev1 ~]# /usr/local/fenbu/replication/bin/rsync --version
rsync  version 2.6.8  protocol version 29

Thanks in advance,


PS: The shell is clean. I tested it.
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list