Deleting...log path

Max Kipness max at
Thu Jun 21 20:19:23 GMT 2007

> On Tue 19 Jun 2007, Max Kipness wrote:
> >
> > For some time I've noticed something that seems very strange to me
> when
> > setting an rsync session for delete.
> >
> > The destination path of the backup is /backup/Latest/Latest/CORP-
> SERVER/ so
> > for new/changed files the logs appropriately report for example:
> >
> > backup/Latest/Latest/CORP-SERVER/....
> >
> > for each file/directory.
> >
> > However, when a file does not exist on the source end, and a
> occurs
> > I get the following bizarre line in the logs for each file:
> >
> > var/www/CORP-SERVER/C$/Corp/User Files/xxx-company/Admin/Property
> > Asstes/Apartments/Sequoia/Photos/
> > Sequoia Bend/DSC03632.JPG:::0:::0:::*deleting
> >
> > I've added the colons to the logging format to easily parse the
> >
> > But why does it show var/www ? /var/www/html/command is where the
> rsync
> %f is basically the full path name, from the module root (/ if you're
> %not talking to a daemon, I believe)
> I think you want %n

The %f settings gives you the full path. This is what I want. The %n
setting gives you just the file name.

I did some further testing and it seems that whenever deleting a file,
%f gives you the path from where the rsync command was run rather than
the path from where the file was deleted. When using %f and the file is
new or has changed, it does properly give you the full path of the file.

Could this possibly be a bug?
> Curious, the manpage doesn't list --log-format as an option :-)  I
> would
> have used --out-format.

It seems that the old setting was --log-format and the new is
--out-format. Evidently the manpage no longer shows the old option, but
it still works. Tried the --out-format setting and it returned the same

> It helps, BTW, if you paste the exact command used, that makes it
> whether you're connecting to a daemon, what the module name is, etc.

Here is the exact command I using for my tests. I'm running it from the
/var/www directory:

rsync -e ssh /test/ --stats --compress
--recursive --partial --archive --delete --times

When adding a new file (test8.txt), the results are just perfect as it
shows the full path of the file:


However, when I turn around and delete test8.txt, the log line
pertaining to that file gives the path that I ran the rsync command


Am I doing something wrong? Or can someone confirm that this is a bug?


More information about the rsync mailing list