Consistent crashes when syncing large file, possible bug?

David Young randomfire at
Sat Dec 1 19:20:25 GMT 2007

Hi, anyone have an idea why it's doing this?  Has anyone else experienced
similar problems syncing from windows to Linux?  Any help would be greatly


On Nov 28, 2007 10:01 AM, David Young <randomfire at> wrote:

> All,
> I'm experiencing a problem where rsync crashes consistently when syncing a
> large file (~760MB).  I am rsyncing from my windows box to my linux server.
> Both ends are running the latest stable version 2.6.9 protocol version
> 29.  The Linux server is a 64-bit version and the windows client supports
> 64-bit.  I've ruled out network by using different switches and also
> verifying that I'm not seeing any error packets on the interfaces.
> Connection is Gigabit.  I've tried both with jumbo frames turned on and off
> and both causes the same error.
> The sync process goes fine until it tries to transfer a large file.  Below
> is the error:
> rsync: writefd_unbuffered failed to write 1 bytes [sender]: Connection
> reset by peer (104)
> rsync: read error: Connection reset by peer (104)
> rsync error: error in rsync protocol data stream (code 12) at io.c(604)
> [sender= 2.6.9]
> Any idea why it's doing this?  Is this a bug or am I doing something
> wrong?
> Thanks,
> David
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list