incoming chmod on daemon fails on subdirectories

Bill Uhl bill at
Fri Sep 22 12:37:57 GMT 2006

Running rsync 2.6.8 as daemon on Fedora core 4. Have the following in 
the rsyncd.conf file...

        path = /home/test/greenlight
#       use chroot = true
        max connections = 3
        lock file = /var/lock/rsyncd/test.lock
        uid = 503
        gid = 503
        auth users = test
        incoming chmod = Dg=s,Dug=rwx,Do-rwx,Fug=rw,Fo-rwx

Uploading a tree from windows with about a dozen subdirectory levels 
over an ssh tunnel with the following command line.

rsync -rczt --modify-window=1 --delete --delete-after --stats -v -v 
--port 35001 "/cygdrive/c/Documents and Settings/dad/My 
Documents/greenlight/" test at localhost::test/

On the first pass, I get this...
    drwxrws--- /home/test/greenlight/linux
    drw-rwS--- /home/test/greenlight/linux/documentation
and the rsync fails to recurse any further down the tree.

On the next pass, the permissions are changed to
    drwxrws--- /home/test/greenlight/linux/documentation
and the next level is created...
    drw-rwS--- /home/test/greenlight/linux/documentation/rsync
Again, rsync fails to recurse any further down the tree. This process is 
repeated in each pass until the whole tree is finally replicated. In the 
meantime, all of the regular files are created with -rw-rw---- 
permissions as expected.

Following is an extract from the daemon's log file...
2006/09/21 04:34:58 [6860] rsync: recv_generator: mkdir 
"/linux/documentation/perl/perl_networking/ch17" (in test) failed: 
Permission denied (13)
2006/09/21 04:34:58 [6860] rsync: stat 
"/linux/documentation/perl/perl_networking/ch17" (in test) failed: 
Permission denied (13)
2006/09/21 04:34:58 [6860] default_perms_for_dir: 
SMB_ACL_TYPE_DEFAULT): Permission denied, falling back on umask

Tried this with and without
    use chroot = true
but it made no difference. Tried changing the order of the chmod 
directives to
    incoming chmod = Fug=rw,Fo-rwx,Dg=s,Dug=rwx,Do-rwx
but it also made no difference.

Am I misunderstanding the chmod stuff and this is behaving correctly or 
is this behavior unexpected?

My goal is to get all of the directories set to
and all of the files set to
throughout the entire tree.


More information about the rsync mailing list