rsyncing as root when root login is disabled?

Linus Hicks lihicks at
Tue Sep 12 12:39:40 GMT 2006

Joe Ruby wrote:
> I'm trying to do a simple rsync:
> rsync -av admin at .
> But a number of files in /backup are readable only by
> root, and hence rsync gives these errors:
> sync: send_files failed to open
> "/backup/etc/mail/virtusertable.db": Permission denied
> (13)
> Since root login is disabled, I can't simple do
> 'root at'. I searched a bit and saw this:
> rsync -av --rsync-path='sudo path'
> admin at .
> I tried it -- rsync asks for my password, but then
> doesn't output anything after many minutes (after
> which I kill it).
> So, how can I rsync files from my remote server so all
> the files are readable and the existing permissions
> get preserved (e.g. not having to do 'chmod -R a+r
> /backup'.

Perhaps what you have shown in your email is incomplete, but based on what you 
have written, you have replaced the remote rsync with sudo. Instead you need to 
invoke rsync using sudo by giving a command to sudo. You might be able to do 
that using the --rsync-path argument like --rsync-path='<sudo path> rsync', I 
have not tried it. Or you could write a wrapper. Google "rsync wrapper".

More information about the rsync mailing list