"Invalid file index" failures, suspicious index numbers

Mailing list subscriptions ushootoo at unixhosts.net
Sat Oct 14 17:32:49 GMT 2006

El 11/10/2006, a las 13:01, Mailing list subscriptions escribió:

> Now, I think the SSH side of things is working fine because dry  
> runs (with the -n switch) work fine but as soon as I try to do a  
> real backup I always bail with an error like this:
> Invalid file index: -1610612736 (count=9406) [sender]
> rsync error: protocol incompatibility (code 2) at sender.c(169)  
> [sender=2.6.8]
> rsync: writefd_unbuffered failed to write 4092 bytes [generator]:  
> Broken pipe (32)rsync: connection unexpectedly closed (195901 bytes  
> received so far) [receiver]
> rsync error: error in rsync protocol data stream (code 12) at io.c 
> (463) [receiver=2.6.8]
> rsync error: error in rsync protocol data stream (code 12) at io.c 
> (1119) [generator=2.6.8]
> Sometimes the numbers are different (-1610612736, 1610612736 or  
> 524288) but the error is always the same: an "Invalid file index"  
> error and rsync subsequently dies.

For what it's worth, I just tried the new 2.6.9pre1 release (on both  
remote server and local machine) and the backup run completed  
successfully. The was about 3 gig of data (150,000 items).

Not sure what the difference is between 2.6.9pre1 and the version I  
tried from CVS only a couple of days ago, but it's working now.  
Perhaps a freak coincidence.

More information about the rsync mailing list