Regarding [Bug 1936] lseek failed in map_ptr

Ryan Kather RDKath at
Wed May 17 14:26:14 GMT 2006

Rsync has begun failing to replicate a kerberos samba mount point.  This mount point has worked previously, but recently an attempt to replicate the mount point returns;

lseek failed in map_ptr
rsync error: error in file IO (code 11) at fileio.c(228)
rsync: writefd_unbuffered failed to write 4092 bytes: phase "unknown": Broken pipe
rsync error: error in rsync protocol data stream (code 12) at io.c(836)
rsync error: received SIGUSR1 or SIGINT (code 20) at main.c(892)

The only thing I have uncovered is a closed Bug 1936.  Has anyone else experienced this?  The rsync version is 2.6.3 running on Novell Open Enterprise Server SP2 (SLES 9 SP3 Equivalent) and syncing with another Novell Open Enterprise Server SP2 (SLES 9 SP3 Equivalent).  The mount point is via smbfs with kerberos authentication against an Active Directory 2k3 domain controller.  The mount is established against a NetApp R200 running OnTap 7.0.1-r1.  

This has all worked previously without issue.  Nothing has changed on the client or server end.  There must be some change in the data on the mount point which rsync does not like.  Thoughts?  


More information about the rsync mailing list