logging problem

Julian Pace Ross julian.paceross at gmail.com
Fri Mar 31 16:50:10 GMT 2006

Yep I tried those two options, and nothing...
Even if the pre-user conf files have a log file in the same directory,
which I touch before trying, messages keep going to syslog... I tried
with 666 permissions on rsyncd.log too just to make sure...

The following is one of the user's conf file, hope theres a clue. Thanks!

log file = /home/pluto/rsyncd.log     <<< This is the problem!! this
rsync.conf is in the same dir.
log format = [From: %a] [To: %m] %o %f %u [Size: %b]
use chroot = false
transfer logging = true

   path = modules/module1
   hosts allow =
   read only = false
   uid = pluto
   gid = users
   incoming chmod = g-rwx,o-rwx
   auth users = pluto
   secrets file = svsec
   strict modes = true
   list = false
   path = modules/syncvlt
   #hosts allow =
   read only = true
   uid = pluto
   gid = users
   list = false

> I bet your per-user rsyncd.conf files specify /var/log/rsyncd.conf but
> the individual users don't have permission to write to this log file.
> Thus the individual rsyncs get EACCES and fall back to syslog.  To fix
> this, you can either grant everyone permission to write
> to /var/log/rsyncd.log (might not be a good idea because one user could
> maliciously alter the other user's log messages) or create per-user log
> files and specify their locations in the per-user rsyncd.confs.
> --
> Matt McCutchen
> hashproduct at verizon.net
> http://hashproduct.metaesthetics.net/
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list