detect renamed still not working

d.laffien at d.laffien at
Sat Mar 4 19:37:46 GMT 2006

Hello there, 

I checked detect renamed in a small scenario again, but it won't work. 

I have some wiles in a dir an moving one to the parent. Rsyncing right 
bevore and after that. The file gets completely new transfered, I can see it 
because of a very slow line. 

This is what I test: 

server:~/test/1 # l new.jpg
 -rwxr-xr-x  1 root root 1628679 Mar  2 00:10 new.jpg*
server:~/test/1 # mv new.jpg ..
server:~/test/1 # l ../new.jpg
 -rwxr-xr-x  1 root root 1628679 Mar  2 00:10 ../new.jpg*
server:~/test/1 # rsync -e "ssh -i /root/.ssh/xxx-rsync-key" -r -p -o -g -v 
 -z -l -t --stats /root/test/ xxx:/root/test --progress -i --detect-renamed
building file list ...
14 files to consider
.d..t.... ./
<f+++++++ new.jpg
    1628679 100%   29.10kB/s    0:00:53 (xfer#1, to-check=12/14)
.d..t.... 1/ 

Number of files: 14
Number of files transferred: 1
Total file size: 17493459 bytes
Total transferred file size: 1628679 bytes
Literal data: 1628679 bytes
Matched data: 0 bytes
File list size: 231
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 1628471
Total bytes received: 54 

sent 1628471 bytes  received 54 bytes  24126.30 bytes/sec
total size is 17493459  speedup is 10.74 

Same with --checksum option. So, whats wrong? I even tried to add
 --compare-dest=/root/test/1 in this case, but won't work too. 

Anyone has any ideas? 

Thanks in advance,
Daniel Laffien

More information about the rsync mailing list