cwrsync server 2.0.4 / winxp / ownership problems?

Erik Jacobs erik.jacobs at
Tue Jan 31 13:29:55 GMT 2006


So I ran this command:

C:\Program Files\cwRsyncServer\bin>xcacls c:\cv7 /T /E /G Administrators:F

But it doesn't seem to have fixed my problem.  It processed all the
files/folders.  I right clicked /stuff and made sure read-only was
unchecked.  I then went to my laptop (WinXP):

"\Program Files\cwRsyncServer\bin\rsync.exe" -vzrLpogtu /cv7/windows/
user at ui7::crystal_windows
building file list ... done

sent 3361 bytes  received 844 bytes  94.49 bytes/sec
total size is 1905087  speedup is 453.05

Then I went back to the UI computer and right clicked a file in
c:\cv7\windows\ and the properties had been reset to read-only!!

Any ideas?

-----Original Message-----
From: Tevfik Karagülle [mailto:tevfik at]
Sent: Monday, January 30, 2006 5:35 PM
To: 'Erik Jacobs'
Cc: rsync at
Subject: RE: cwrsync server 2.0.4 / winxp / ownership problems?

Hi Erik,

Since cwrsync contains some windows-specific arrangements not directly
related to rsync itself, I've
established a cwrsync discussion forum half a year ago. It is available at
may consider to post your problem at this forum as well.

Back to your problem: By default, cwrsync is configured to not to map unix
permissions to windows
equivalents (env.variable CYGWIN=nontsec). In other words, what you set as
windows permissions on
your directories will not be disturbed by cwrsync. If you want to give your
admins write permissions
on /stuff/windows, you may simply run the command below only once:

Xcacls "windows directory behind module crystal_windows" /T /E /G

Best regards


cwRsync maintainer

> -----Original Message-----
> From: at
> [ at] On
> Behalf Of Erik Jacobs
> Sent: 30. januar 2006 22:25
> To: rsync at
> Subject: cwrsync server 2.0.4 / winxp / ownership problems?
> Hi all!
> We're using cwrsync server 2.0.4 on winxp to keep files up to
> date between some operator machines.
> Whenever I run rsync to send files to another machine, the
> read-only flag gets set.  The cwrsync user was created (the
> install is completely standard)... so I'm thinking it might
> have something to do with that.
> Here's my rsyncd.conf:
> use chroot = false
> strict modes = false
> hosts allow = *
> log file = rsyncd.log
> pid file =
> [crystal_windows]
> path=/stuff/windows
> read only=false
> comment=some stuff
> When I run the following command from my laptop:
> rsync -vzrLpogtu /stuff/windows/ user at node7::crystal_windows
> It sets *ALL* the files in the /stuff/windows folder on the
> remote machine to read-only.
> This is a big problem because it means that when an operator
> goes to edit a file in the windows folder with a program, he
> has to first make the file not read only.
> Is it possible to change the cwrsync configuration so that it
> runs as the same user that the operator logs in as?  I'm
> thinking that for some reason windows is getting confused and
> setting the ownership to the cwrsync user and that's why the
> operator user sees the file as read-only.  Because the
> operator is an administrator, the read-only can be turned
> off, but every time rsync touches the folder it seems to
> reset all the permissions settings.
> Thanks in advance!
> --
> To unsubscribe or change options:
> Before posting, read:

More information about the rsync mailing list