IO error encountered -- skipping file deletion

Master Abi master at
Sun Dec 10 10:14:07 GMT 2006

Thanks for answer. I found the problem. It was a zero byte file on the 
Windows server. I don't know if this is a cygwin or rsync issue that 
cannot handle 0byte files.

I have tested it on another server with a 0 byte file and the same 
happens. I will investigate further

Matt McCutchen wrote:
> On 12/6/06, Master Abi <master at> wrote:
>> I have a Windows server backing up to a Linux server that continuously
>> gets 'IO error encountered -- skipping file deletion' in the receiver
>> log file. Could someone enlighten me where and what this error is
>> referring to. I have tried various options, like using --delete or
>> --delete-during. Still the same problem.
>> Is it on the sender or receiver side, or a timeout encountered 
>> somewhere.
> That message indicates that there was an error on the sender during
> file-list building.  The sender should have printed a separate message
> indicating what the error was, but the message might have been
> suppressed due to -q.  Rsync reasoned that the error may have
> prevented it from seeing some of the files on the sender.  To avoid
> naively deleting their counterparts on the receiver, it skipped the
> deletion phase altogether.  If you want it to delete anyway, use
> --ignore-errors.
> Matt

More information about the rsync mailing list