Can not rsync certain folders a second time

Eden Greyfaulk eden.greyfaulk at
Wed Aug 2 13:22:21 GMT 2006

I am running a windows xp machine and running the latest version of rsync, i am using a naslite server that is the rsync server,  when I run the following commands to copy data from my xp machine to my nas it will copy the data the first time but if i pick up email and then run the command again it will freeze with a error, But if i just use a folder that has say my downloads in and i alter a file here it will ok, 

if you want to test this you will need to use your settings and your code after identities.

rsync.exe  -v -rlt "/cygdrive/C/Documents and Settings/eden/Local Settings/Application Data/Identities/{D43979E3-361F-4827-A8E9-59A22FDE7806}/Microsoft/Outlook Express/" " Express/"

rsync.exe  -v -rlt "/cygdrive/C/Documents and Settings/eden/Favorites/" ""

rsync.exe  -v -rlt "/cygdrive/C/Documents and Settings/eden/Application Data/Microsoft/Address Book/" " Book/"

rsync.exe  -v -rlt "/cygdrive/C/Documents and Settings/eden/My Documents/" " Documents/"

Here is a example of the error.

Executing: rsync.exe  -v -rlt "/cygdrive/C/Documents and Settings/Eden Greyfaulk/Local Settings/Application Data/Identities/{D43979E3-361F-4827-A8E9-59A22FDE7806}/Microsoft/Outlook Express/" " Express/"
building file list ... 


Deleted Items.dbx


rsync: read error: Connection reset by peer (104)

rsync error: error in rsync protocol data stream (code 12) at /home/lapo/packaging/tmp/rsync-2.6.6/io.c(584)

if i delete the files on the nas and run the command again it will copy it but will lock the pc if i attempt a second time once a file has chnaged.

I have run this command of another pc and it still happens, and i even made a windows pc a rsync server without using the nas and i still get a failure.

thanks for taking a look at this and i hope you can help me resolve this.

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list