issues with password-file

Larry Hotchkiss larryhotch at
Sat Apr 1 00:52:30 GMT 2006

I have rsync daemon running on a fedora core 4 box that I am trying to use 
as a backup server for my web sites. I dont have shell access on my web 
host so will need to run a cron job to do the backups, which is what I want 
to do anyway.

For testing purposes however I am using a php script using the "system()" 
function so I am getting some feedback.

In my rsyncd.conf file I have the following very simple module for testing 

max connections = 2
syslog facility = local3
log file = /var/log/rsyncd.log

	uid = lhotch
	gid = lhotch
           comment = test area
           path = /lhotch
           read only = no
           list = yes
	use chroot = yes
           hosts allow = xx.xx.xx.xx
	auth users = larry
	secrets file = /etc/rsyncd.secrets

from the web host when I run the following command

rsync -P -v -W -r --password-file=/path/secrets.rsync * 
larry at xx.xx.xx.xx::lhotch/

now in the above, I have substituted the real IP that im using with x's and 
the path to the secret file is a valid absolute path to secrets.rsync(which 
contains only the password that matches the one in rsyncd.secrets). My 
/etc/rsyncd.secrets file has its permissions set at 600 and the rsync 
daemon is running under root.

If I run just this command

rsync xx.xx.xx.xx::

I get the available modules so I know the 2 servers are talking. 
Additionally if I remove the auth users and secrets file directives from 
rsync config All of the files from the directory where the script is run on 
down get copied so everything seems to be working but authentication. I 
tried changing the hosts allow to an ip other than the one I am running the 
command from and the transfer doesnt work so that also seems to be working.

On every failed attempt however with auth users and secrets file in 
rsyncd.conf I do get 2 errors in the log...

2006/03/31 17:45:00 [3494] forward name lookup for failed: Name or service not known
2006/03/31 17:45:00 [3494] auth failed on module test from unknown 

So, it seems the reverse DNS looking cant be resolved yet the auth users 
seems to still work and then I assume the next error is that auth for the 
user failed.

Can anyone shed some light on what I am doing wrong?


More information about the rsync mailing list