"missing secret for user" using cygwin rsync on Windows XP Home

Andrew Moore andymoore at cheerful.com
Tue Sep 27 13:38:44 GMT 2005


I'm trying to set up rsync to allow me to backup a number of Windows machine to a Windows XP Home server using Nasbackup.

I can get rsync working fine but have been struggling for days to get user authentication working.


2005/09/27 13:46:37 [1352] rsyncd version 2.6.6 starting, listening on port 873
2005/09/27 13:47:50 [4088] auth failed on module modulename from localhost ( missing secret for user "me"


use chroot = false
strict modes = false
log file = /var/log/rsyncd.log


	path = /cygdrive/c/cygwin/home/backups
	comment = Rsync storage area
	read only = false
	auth users = me
	secrets file = /cygdrive/c/cygwin/etc/rsyncd.secrets



The server was started with the following command line:

cygrunsrv.exe -I "Rsync" -p /cygdrive/c/cygwin/bin/rsync.exe -a "--config=/cygdrive/c/cygwin/etc/rsyncd.conf --daemon -cc -no-detach" -f "Rsync daemon service"
net start rsync

The Rsync service is starting.
The Rsync service was started successfully.

The client was started with the following command line:
rsync -vvr /cygdrive/c/folder localhost::modulename
opening tcp connection to localhost port 873
opening connection using --server -vvr . modulename
@ERROR: auth failed on module modulename
rsync error: error starting client-server protocol (code 5) at /home/lapo/packaging/tmp/rsync-2.6.6main.c(1171)

As shown above, authentication is failing because it is not picking up the secret for the user.

I have tried the forums, web searches etc and have tried tons but nothing seems to work.

Any other ideas?

Thanks very much,

Sign-up for Ads Free at Mail.com

More information about the rsync mailing list