SOLVED: files are copied but setting time stamp fails

Nick Demou (enLogic) ndemou at
Thu Oct 13 08:06:19 GMT 2005

Matt McCutchen wrote:
> On Wed, 2005-10-12 at 12:08 -0700, Wayne Davison wrote:
>>Setting the current time may be allowed where setting an arbitrary
>>time is not (for instance, I know of an OS where directories are treated
>>that way).
> On Linux, you only need to be able to write a file to set its access and
> modification times to the current time, but you need to own it to set
> its times arbitrarily, as rsync does when preserving times.  This makes
> me think that rsync can write the destination files but doesn't own
> them.

Yes Matt, that was it!

> You said you are using vfat, which explains everything.  Vfat cannot
> store ownership, so all of the files on a vfat partition have the same
> user and group owners; these owners can be set via the "uid" and "gid"
> mount options.  Other users (like the one rsync is running as) might
> have write permission, but even if they create files, those files will
> belong to the partition-wide user owner.
> If you want to preserve times, you should change either the user running
> rsync or the user owning all the files on the partition so that they
> match, 

I've changed the owner on the mount command and everything worked just fine


> or you should use a different filesystem.

it's a usb disk I use to move data around to linux and windows PCs so 
this was not an option

More information about the rsync mailing list