files are copied but setting time stamp fails

Nick Demou (enLogic) ndemou at
Fri Oct 7 13:57:27 GMT 2005

I am using this command:
#rsync -tr /home/ndemou/test/ /media/MOB1/m/test/

has only one file named "1" (without the quotes)

is empty and it's on a vfat partition mounted as

#mount /dev/sda1 /media/MOB1/ -t vfat -o iocharset=utf8,umask=000

The file 1 is created at the destination but I get this error "failed to 
set times on "/media/MOB1/m/test/.1.yAg2dp" and as you expect the time 
is not copied from source

If I do the same but on a non-vfat partition everything is OK so I 
thought it has something to do with the way the kernel driver handles 
the case of the filenames in vfat partitions but I have tried all 4 
shortname=lower/win95/winnt/mixed and none worked

Any help would be welcome.

Below is a copy of the output of the command:
$ rsync -vv -tr /home/ndemou/test/ /media/MOB1/m/test/
building file list ...
[sender] expand file_list to 131072 bytes, did move
delta-transmission disabled for local transfer or --whole-file
rsync: failed to set times on "/media/MOB1/m/test/.1.QKjE7e": Operation 
not permitted (1)
total: matches=0  tag_hits=0  false_alarms=0 data=0

sent 87 bytes  received 40 bytes  254.00 bytes/sec
total size is 0  speedup is 0.00
rsync error: some files could not be transferred (code 23) at main.c(702)

More information about the rsync mailing list