File transfer from/to mapped drive with cygwin rsync

sanalkumar.siva at sanalkumar.siva at
Thu Nov 10 12:27:37 GMT 2005

Hello Wayne,

	Thanks for the reply,

	We tried with cygwin style path also. Still we are getting the
same error.

	Following is the error from rsync server log:

2005/11/10 17:44:32 [1716] rsync: chdir /cygdrive/i/check failed
: Permission denied (13)

	Where I: is a mapped drive in Windows. We've provided the full
access to I: for everybody.

	Will the upgrade to latest rsync will help? We are using rsync

Thanks in advance,

-----Original Message-----
From: Wayne Davison [mailto:wayned at]
Sent: Thursday, November 10, 2005 5:30 AM
To: Sanal Kumar Kariazhath Sivaraman (WT01 - Broadband Networks)
Cc: rsync at
Subject: Re: File transfer from/to mapped drive with cygwin rsync

On Wed, Nov 09, 2005 at 09:11:52PM +0530, sanalkumar.siva at
>     @ERROR: chdir failed

Just read the server's log file to discover what directory was being
attempted in that chdir() call (rsync doesn't like to reveal such info
from the daemon to the client).  I'm guessing you're trying to use a
DOS-style path, which is not supported by rsync (use a cygwin-style


Confidentiality Notice

The information contained in this electronic message and any attachments to this message are intended
for the exclusive use of the addressee(s) and may contain confidential or privileged information. If
you are not the intended recipient, please notify the sender at Wipro or Mailadmin at immediately
and destroy all copies of this message and any attachments.

More information about the rsync mailing list