Possible bug not deleting files

Omen Wild omen+rsync at mandarb.com
Fri May 27 03:06:36 GMT 2005

I am using rsnapshot <http://www.rsnapshot.org/> to make snapshots of
my filesystem.  rsnapshot uses rsync to do all the heavy lifting.  I
was recently browsing my snapshots and discovered that none of the
excluded files or files deleted in the source are getting deleted from
the snapshot. rsnapshot calls rsync like this:

/usr/bin/rsync -a --delete --numeric-ids --relative --delete-excluded \
 --exclude-from=/home/omen/.backup/rsnapshot \
 /home/ \

When I run the same command but add '--dry-run -v -v' I get a single
line about deleting files:
deleting in home/.

Then it moves on to showing the uptodate files.

If I remove the trailing slash from '/home/' in the command, then I get
the line:
deleting in home
deleting [snip]

Followed by 30,000 lines of the other files that will get deleted.

I tried applying the patch in
but rsync then totally skips even the 'deleting in home/.' line.  The
log goes like this:
[sender] excluding file [snip]~ because of pattern .*~
delta-transmission disabled for local transfer or --whole-file
[snip] is uptodate

It seems to me that the presence of a trailing slash should not cause
the files to not get deleted.

I have not yet begun to byte!

More information about the rsync mailing list