rsync: mkstemp failed: No such file or directory (2)

apache7 at apache7 at
Fri May 13 14:35:54 GMT 2005

Hello everyone,

Server1: Harmony
Server2: Peace

I've been using rsync 2.6.4 since some time now, without any problem.
I "copy" files from Server2 to Server1 (making Server1 a mirror of Server2).

The command line used on Server1 was:
    rsync -vrlpogt --delete-after Server2::Img/ /LocalImg

I was copying files from Server2 (module Img) to Server1 (in /LocalImg).
We had a problem with Server2, so I had to format the partition. Now, I'm 
trying to copy back the files to Server2 from Server1.

I tried the following command on Server1:
    rsync -vrlpogt --delete-after /LocalImg/ Server2::Img

The directories were created on Server2, but no files were copied!
I got the following error message repeating for each file it failed to copy:
rsync: mkstemp "/tmp/.008902000072_0181.PNG.KnfE9V" (in Img) failed: No such 
file or directory (2)

I tried rsync 2.6.5pre1 but got the same problem.

By the way, I have rsync running as daemon (as root) on Server2. The config 

uid = root
gid = root
log file = /var/log/rsyncd.log

   path = /Img
   list = yes
   read only = no

Can anyone help me to solve this problem?

Thanks for any help. 

More information about the rsync mailing list