Unnecessary directory listing.

Julian Pace Ross duendecito at gmail.com
Thu May 12 15:36:40 GMT 2005

I'm an rsync newbie, and I have been using it for some weeks without
problems... except recently...

Just a quick explanation:
I have Suse9.0 and rsync 2.5.6 that came with it...
I have a cron script that contains:

rsync -av --delete /myfolder/

in order to sync all files (and remove deleted ones)  with the file
On the latter there is an rsync server running.

The problem is that since a couple of weeks ago, when running the
script, I get a full list of the directories and not just the changed
Directory1/ Directory2/
Directory1/ Directory3/
Directory1/ Directory4/ 
Directory1/ Directory5/Directory6/......
....and so on (hundreds of lines)

It is not actually updating any of the files since it scrolls past
very fast (whole process takes a few sec for about 4GB) and I only get
a few bytes sent and received.
The strange thing is that if I run the script more than once in
succession, it only happens the first time..... I wait a few minutes
and retry.. and it happens again.

I tried everything from syncing the time on the 2 machines to deleting
some directories on the file server to "refresh" the process... but in

Any ideas???


More information about the rsync mailing list