filename paths different in server mode

Bob Proulx bob at
Wed May 4 06:03:04 GMT 2005

Wayne Davison wrote:
> On Tue, May 03, 2005 at 05:26:10PM -0600, Bob Proulx wrote:
> >   $ rsync -a ewok::cadroot/release/bin/ .
> >   $ ls
> >   bin
> Is your shell stripping off trailing slashes? 

Good thought.  But no.  Running bash.  But here is a test for that.
What you see is what you get.

  echo rsync -a ewok::cadroot/release/bin/ .
  rsync -a ewok::cadroot/release/bin/ .

> Try running a basic shell, such as /bin/sh and see if that makes a
> difference.


> You can also use the -vv option to display the command that rsync is
> sending to the remote daemon to see if the trailing slash is still
> there or not (2.6.4 mentions the command where earlier rsync
> versions did not).  I'm doubtful that this is caused by rsync.

Is two v's different than four v's?  I gave it four v's to see the
protocol that was negotiated.

> > Command to access the server:
> >
> >   rsync -avvvv ewok::cadroot/release/bin/ .
> >
> >   opening connection using --server --sender -vvvvlogDtpr

I thought that was that information.  Isn't it?

> One potential work-around:  try adding a trailing dot after the slash:
>   $ rsync -a ewok::cadroot/release/bin/. .

Good thought.  I already tried that.  No difference.  I also tried all
of the combinations of . ./ ./. in both source and destination.  I am
sure the problem is on the server side of the process.

Its's a strange problem...


More information about the rsync mailing list