Hard links revisited

Scott Lovenberg scott.lovenberg at gmail.com
Tue Jun 7 14:51:19 GMT 2005

I can't seem to get the hardlinks to work in windows via --link-dest. 
It just refuses to find the files in the directory and make a hard
link.  Here's the setup.
-I run 2 rsyncs from batch files called sync.bat and sync2.bat.  
-I'm connected to the server via a mapped network drive, we'll call it 'z'.  
-I then run the client, on the destination, once to pull the data from
the server and make a base-level mirror in a  directory I call
-Next, I want to run the backup again and put it in a different
directory called "mirror", but only hardlink the files that already
exist in my base-level mirror.

Every time that I run the first backup to "source", everything works
fine and all of the files are moved to the location desired.  Then
when I run the second backup, which is supposed to hardlink to the
first one if the file already exists, it merely copies all the files
and doesn't make a single hardlink.

sync.bat, first backup (z is the mapped network drive,destination is
#the machine I am on)
"c:\program files\cwrsync\rsync.exe" -avr --stats                 
"/cygdrive/z/users/scott's folder/testBackup/"           

#sync2.bat second backup - should use hardlinks
"c:\program files\cwrsync\rsync.exe" -avr --stats
--link-dest="/cygdrive/c/source" "/cygdrive/z/Users/Scott's
Folder/testBackup/" destination::testHardLinks

path = /cygdrive/c/source/
read only = false
transfer logging = yes
path = /cygdrive/c/Mirror/testBackup/
read only = false
transfer logging = yes

Any ideas?  I've tried nearly everything that I could think of that
had even the slightest modicum of validity for a resolution.  Nothing
works yet.

"Of course, that's just my opinion; I could be wrong"
-Dennis Miller

More information about the rsync mailing list