please help -- Variable syntax error

Govindarajan, Bhadri bhadri.g at
Sat Jun 4 15:46:17 GMT 2005

I typed exactly without any variables in the command line. No variable 
It works perfectly in one other machine where the shell is ksh.(That is the 
only difference between the machines i know of)
>>rsync -vv testfile mydestmachine:/export/opt/geneva/temp/testfile
Here testfile is a simple text file with 2 lines. When i did this with scp, 
it worked.

----- Original Message ----- 
From: "Paul Slootman" <paul at>
To: <rsync at>
Sent: Saturday, June 04, 2005 6:42 AM
Subject: Re: please help -- Variable syntax error

> On Fri 03 Jun 2005, Bhadri N Govindarajan wrote:
>> I am using rsync to sync w machines. I had no problem untill. Now i am
>> trying the same script  to sync 2 differnt machines.  The code is the
>> same. I just changed the machine names.  When i execute the script i
>> get
>> Variable syntax
>> rsync: connection unexpectedly closed (0 bytes read so far)
>> rsync error: error in rsync protocol data stream (code 12) at io.c(150)
>> I am able to scp or ssh to the from the machines. I have proper keys.
>> Where does the Variable syntax come from., I have 5 folders in include
>> file. So this error is repeated 5 times.
> "Variable syntax" is a csh error message telling you that the way you're
> trying to use shell variables is wrong somehow.
>> I tried
>> rsync -vv testfile mydestmachine:/export/opt/geneva/temp/testfile
>> even for this command i get the same error.
> You typed this at the commandline, exactly as shown, and it gave you
> this error? That's strange, as no variables are involved here.
> 'rsync' doesn't happen to be an alias, does it?
> Paul Slootman

More information about the rsync mailing list