rsync transmits unchanged data

Martin Kammerlander csad3934 at
Wed Jul 27 08:36:05 GMT 2005

hi all!

I tried to synchronise a directory with the following command:

rsync -avz --exclude "db/" /source/ /destination/folder/ --delete

The source has 3 subfolders one of them is not necessary for to synchronize so i
exluded this folder.
everything works fine and fast :) excludes were made...and all seems ok
The data on the source folder changes every day once.

But there is still one "problem": i tried to execute this command several times.
Sometimes rsync gives me the following output:

building file list ... done

sent 2801 bytes  received 20 bytes  5642.00 bytes/sec
total size is 28151695  speedup is 9979.33

So everything is up to date no changes were made...this is how it should be!

But mostly rsync copies always the same files of a certain folder again to the
destination folder...although REALLY no changes were made to the files!?

rsync copies not all files of the this certain folder but only a few of them...

Sombody knows what's going wrong here...or maybe what is more likely: what I'm
doing wrong on my command?

thanks for any suggestion

More information about the rsync mailing list