rsync error ?

Shitong.Wang at Shitong.Wang at
Tue Jul 5 20:33:36 GMT 2005

I'm not sure it is a real error or not,  when I run 'rsync' with no 
options on AIX 5.3, it has an error at the bottom of usage message, see 

# rsync
Use "rsync --daemon --help" to see the daemon-mode command-line options.
Please see the rsync(1) and rsyncd.conf(5) man pages for full 
See for updates, bug reports, and answers
rsync error: syntax or usage error (code 1) at main.c(1097)

I know it is not a correct syntax to run 'rsync' without arguments, 
however, the error above give me the impression that this version of rsync 
is poor in error handling... I don't see this kind of error in previous 
version such as 2.4.5 ( I used this version before). 

Is there any way I can get rid of this kind of 'error' message if it is 
not a real bug, just some debug information. I have tried to re-compile 
rsync source with --enable-debug=no, but it doesn't work. 

Any help would be appreciate !


Shitong (Steve) Wang

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list