UNC path issue

Trey Nolen tnolen at internetpro.net
Thu Feb 10 22:43:41 GMT 2005

I'm using rsync and cygwin to do some backups from Windows machines.  I have 
been doing something along these lines:

c:\cygwin\bin\rsync -aR -e 
c:\cygwin\bin\ssh.exe --numeric-ids --delete --delete-after --verbose --ignore-errors 
 --exclude-from=/cygdrive/c/offsitebackup/excludes.txt /cygdrive/c/ 
root at remotehost

This all worked well until I had to do backups of several mapped drives from 
one machine.  I specified those drives with something like /cygdrive/f/ for 
the F: drive and that worked OK.  The problem is, one day someone logged out 
of the server and the maps went away. When the backup job ran, it deleted 
all the files in the backup because the mapped drives weren't there anymore. 
So, I decided to use UNC paths since they exist all the time, but it didn't 
work and I found in the archives that rsync considers // the same as /. 
There was a suggestion to change directory first and then run the job, but I 
don't think that will work in this case.  Does anyone have an idea of how to 
backup remote machines using cygwin without being logged in?

Trey Nolen

More information about the rsync mailing list