getting rsync to work +automating password line

Gil Naveh gnaveh at
Thu Feb 10 17:57:30 GMT 2005

Thanks Paul,

The --rsync-path=PATH did the work. :)
Is there a doc that shows all the options that comes with rsync? - when I
tried #rsync --help
I did not get the --rsync-path option.
Finally, the next step for me is to automate rsync through crontab. But when
I type rsync -a e ServerB/... I get a prompt for #password:
I tried rsync with the option --password-file=/name/of/file/with/password
but it still asked me for password!

Thanks much,

-----Original Message-----
From: Paul Slootman [mailto:paul at]
Sent: Thursday, February 10, 2005 12:13 PM
To: Gil Naveh
Cc: rsync at
Subject: Re: getting rsync to work

On Thu 10 Feb 2005, Gil Naveh wrote:
> I am trying to do a very simple thing, just transfer a file from machine A
> to machine B using rsync with ssh.
> This is what I'm typing:
>  # rsync -a -e ssh serverB:/tmp/rsync/test1 n serverA:/tmp/rsync/
>  #  password: XXXXX
> This is what I get:
> # bash: rsync: command not found
> # rsync: connection unexpectedly closed (0 bytes received so far)
> # rsync error: error in rsync protocol data stream (code 12) at io.c(359)
> Basically it seems to go wrong after logging into the remote machine when
> says "bash: rsync: command not found".
> rsync is definitely installed on both machines which are Solaris9 and is
> the user's
> environment path. So I don't understand why it says "rsync: command not
> found"...?

.profile etc. is typically not read when executing a command via ssh.
That's why the  --rsync-path=PATH  option was invented.
Add that (with the correct path to the rsync binary on the remote!)
and things should start working.

PS: what's the 'n' doing between /test1 and serverA: in your command?
I hope it's a typo...

Paul Slootman

More information about the rsync mailing list