Those darned 'ol spaces in path/file names...

Clay Goss ClayGoss at
Wed Feb 9 17:42:08 GMT 2005


I am really struggling with the "spaces in the path/file name" thing.

Some stuff I have figured out - some I haven't.  Take this one:

	- PC with WindozeXP Pro
	- Cygwin (just updated)
	- Files in folder (from cygwin root)
		/bob smith/sally smith/
	- Using ssh to secure the link
	- Typical rsync command:
		rsync -e ssh -vazP <source path>
<user><destination path>

	- FC3 (just updated)
	- Destination folder:
		/disk2/larry jones/bonnie jones/

	- rsync on FC3 creates a directory named /disk2/larry/ and copies
the contents of /bob smith/sally smith/ into it.
Syntax tried:

rsync -e ssh -vazP '/bob smith/sally smith/'
<user>'/disk2/larry jones/bonnie jones/'
rsync -e ssh -vazP "/bob smith/sally smith/"
<user>"/disk2/larry jones/bonnie jones/"
rsync -e ssh -vazP /bob\ smith/sally\ smith/
<user>\ jones/bonnie\ jones/

And combinations using the left of one of the above and the right of the

I have also tried an example using "echo <path stuff> | rsync..." but didn't
understand the author's intent and didn't get it to go either.

Any ideas are greatly appreciated.


More information about the rsync mailing list