rsync with ssh problem please help me

gg gg234 ggs234 at
Tue Dec 20 13:20:30 GMT 2005


I am planning to create a backup using rsync with ssh.I am running debian
linux for this.

I am trying to do the new installation of rsync for this i an trying to
create a key and i have logged in as "back" and try to run ssh-keygen -t rsa
for creating key and it went well until here after that i am trying to copy
this key file to destination machine using

ssh-copy-id -i ~/.ssh/ backup at destination ip

this time i am getting the following error

# ssh-copy-id -i ~/.ssh/ backup at destination ip
bash: line 1: .ssh/authorized_keys: Permission denied

I have changed the permissions of file to 770 and in remote
machine i have changed the authorized_keys file permissions to 770 but still
i am getting same error.This is happening whenever i try to copy using the
user name and when i try to copy using root it is working fine.I tried to
change the permissions of .ssh folder to 770
but still the same problem.

Thanks for your help
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list