Rsync 2.6.3 does not show to be deleted files. Bug?

Gerben Wierda Gerben.Wierda at
Sun Aug 21 20:43:30 GMT 2005


I am running rsync 2.6.3 on Mac OS X 10.4. I have set up rsync to act  
as rsync server on one machine with a module entry like this:

syslog facility = local5

         path = /usr/local/src
         comment = whole /usr/local/src tree
         hosts allow = [ip addresses deleted]
         hosts deny = *
         uid = gerben
         gid = staff
         read only = no

I have an entry in my ~root/.ssh/authorized_keys which says:

command="rsync --server --daemon .",no-port-forwarding,no-X11- 
forwarding,no-agent-forwarding ssh-dss [key deleted] gerben at hermione-

Now, when I run:

rsync --dry-run --progress --delete -avvu -e "ssh -l root -i $ 
{HOME}/.ssh/id_rsync" gerben at hedwig::src-rw/ /usr/local/src

I get stuff like

deleting in ...
deleting libpng-1.2.8/%makefile
deleting i-Packages/tex/tex-perf-results.html

but when I run it the other way around:

rsync --dry-run --progress --delete -avvu -e "ssh -l root -i $ 
{HOME}/.ssh/id_rsync" /usr/local/src/ gerben at hedwig::src-rw

I get no such delete messages, but files will be deleted. When I look  
at the log file where rsync logs to I see:

Aug 21 22:31:37 hedwig rsyncd[24738]: deleting i-Packages/tex/.tar- 
Aug 21 22:31:37 hedwig rsyncd[24738]: deleting i-Packages/tex/.tar- 
Aug 21 22:31:37 hedwig rsyncd[24738]: deleting i-Packages/%basicii2.make
Aug 21 22:31:37 hedwig rsyncd[24738]: CURLHandle/10.2+ compatible/ -> tmp/ 
Aug 21 22:31:38 hedwig rsyncd[24738]: dante-1.1.13/dlib/Raccept.c - 
 > ../lib/Raccept.c

Is there a way in this setup that I can let rsync when going upstream  
actually show on the client side what will be deleted on the server  

When I do not use an rsync daemon at the other side (which was my  
previous setup) I do get the "deleting" messages both ways.



More information about the rsync mailing list