Rsync, Samba & Specia Characters

Linda A. Walsh rsync at
Thu Aug 18 16:02:59 GMT 2005

I have a similar problem, but it is also in the 'find' command
on a windows box.  Are you, per chance, running the cygwin port
of rsync?

Whether or not, you might try a simple experiment -- see if you
can move the affected file(s) using Explorer Windows.
Also check if you can see the correct filenames when you log
onto the linux box via the console.  If that doesn't work,
then you need to change (most likely) your Linux server and
samba setup to speak in UTF-8 (universal character set).  It's
compatible with all world languages and both Windows and
linux servers w/samba play together nicely with international
characters.  If that doesn't work, you need to configure
your server to speak UTF-8.  That's beyond the scope of
this list.  You could switch to an international supporting
distro like SuSE that is configured to use UTF-8 compatible
characters out of the box.   (RedHat may be as well, I just
don't use it, to know). 

If you can work with the files in Explorer and they are also
viewable on your linux box, then you know windows and your
server are working together, but cygwin based programs choke
on non extended-latin1 characters.  Symptoms of this error
are messages like:

/m/world/omar> ls Süleyan\ the\ Magnificient/
ls: Süleyan the Magnificient/01 Istanbul'dan Görüntüler.mp3: No such 
file or di
ls: Süleyan the Magnificient/17 Istanbul'dan Görüntüler (Reprise).mp3: 
No such
ile or directory
ls: Süleyan the Magnificient/10 Süleyman?n Öyküsü.mp3: No such file or 

ls: Süleyan the Magnificient/02 Gögü Yedi Kat?.mp3: No such file or 
ls: Süleyan the Magnificient/08 Topkap?n?n Bahçesi.mp3: No such file or 
ls: Süleyan the Magnificient/11 Teke Z?plamas?.mp3: No such file or 
ls: Süleyan the Magnificient/13 Segâh Pesrev.mp3: No such file or directory
ls: Süleyan the Magnificient/15 Hicaz Pesrev.mp3: No such file or directory
ls: Süleyan the Magnificient/05 Ussak Semai.mp3: No such file or directory
03 Egeli Gemici.mp3     07 Kuzeydeki Köy.mp3  14 Hicaz Taksimi.mp3
04 Aya Sofya.mp3        09 Rast Medhal.mp3   16 Makber.mp3
06 Nihâvend Fantazi.mp3  12 Mevlânâ.mp3
The files it has problems with are certain arab or greek characters in my

I've seen the problem mentioned on the cygwin mailing list, but have
not seen any solutions or acceptable workarounds.  Since cygwin is a
console-based program, it uses the 'console's settings of a code page
see output of ''.  I've tried setting my codepage to UTF-8, but
that caused worse problems:
Before (code page 850, default):
/m/world/omar> ls
Dance Into Eternity/  Süleyan the Magnificient/  mystical garden/
Fire Dance/           Whirling/
setting codepage to UTF-8:

/m/world/omar> con codepage select=65001

Status for device CON:
    Lines:          9999
    Columns:        80
    Keyboard rate:  31
    Keyboard delay: 1
    Code page:      65001

/m/world/omar> ls
Dance Into Eternity/  Fire Dance/           Whirling/
ls: write error

Good luck in getting the cygwin folks to fix this....they are a
bit over-worked, and support for characters outside of the ISO
Latin-1 characters
isn't a high priority compared with other issues.

It's one of my 'back burner' issues to try to track down and see what is
necessary to make it work, but since it only affects a small number
of my music files, and only run into the problem with I use rsync to
sync my "music archive" with my portable MP3-player, I usually just
"deal" and copy those directories by hand if they need to be updated.

Hope this helps and sorry to all for the longwinded, mostly Off-topic


Fernando Guarino wrote:

>Hi everybody!
>I´m in Argentina and we speak spanish. My problem is that when I try to
>use rsync to perform a backup from a windows xp machine to a linux
>red hat 9 server it changes the special characters, and everithyng is a miss.
>How can I find a solution for this?

More information about the rsync mailing list