rsyncd server daemon not allowing connections

todd at todd at
Mon Apr 25 16:24:31 GMT 2005

Christoph, thanks for your reply.  Comments below:

> todd at wrote...
>> I'm trying to run rsync in server mode and it appears to start normally,
>> but it refuses all connections (refuses connection when I tried
>> telnetting
>> in on localhost 873!).
> Did the daemon acutally start?
> What does "netstat -ln | grep :873" tell?

Returns nothing!  Other services show up in netstat (e.g., webmin on
10000), but nothing at 873

>> rsync --daemon --server --config-file=/etc/rsyncd.conf .
> As a test: add --no-detach and watch whether the daemon dies.

tried it, and it doesn't die..  15 minutes and still there in ps...

>> log file = /var/run/rsyncd.log
> This file should contain some information.

Now it does (gremlins):

2005/04/25 11:15:01 [2671] rsync error: received SIGUSR1 or SIGINT (code
20) at rsync.c(225)

I just googled quickly (will do more) and didn't find much on this, except
that it could be a permissions issue?...

Again, thanks for your help!
>     Christoph
> --
> To unsubscribe or change options:
> Before posting, read:

More information about the rsync mailing list