[Bug 1812] New: fuzzy not working in 2.6.3-pre{1,2}

samba-bugs at samba.org samba-bugs at samba.org
Thu Sep 23 10:56:13 GMT 2004


           Summary: fuzzy not working in 2.6.3-pre{1,2}
           Product: rsync
           Version: 2.6.3
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: core
        AssignedTo: wayned at samba.org
        ReportedBy: egmont at uhulinux.hu
         QAContact: rsync-qa at samba.org

The --fuzzy option, which I regularly use and saves me an extremely huge amount
of time and worked perfectly up to 2.6.2, doesn't work at all in 2.6.3-pre1 and

Please see bugzilla #1489 for a description of a bug in 2.6.2 which would make
it important for me to upgrade to 2.6.3.

I downloaded rsync 2.6.3-pre1 and pre2, applied g2r-basis-filename and fuzzy
patches (fuzzy says it needs the former one), ran "make proto; make" as these
patches tell me to do, and then I installed the new version.

While the old 2.6.2 version runs perfectly, the new ones seem to completely
ignore the --fuzzy option.

Here's the exact, detailed (and boring) description of what I do:

On a remote machine, created a directory 'foo' and dd'd one megabyte of
/dev/urandom to foo1.txt and then copied foo1.txt to foo2.txt.
Then I created 'foo' directory on the local machine and copied foo1.txt here.

Then I executed the following command several times:
rsync -avP --fuzzy --bwlimit=10 remotemachine:foo/ foo/
(and of course removed local foo/foo2.txt before each run of this command).

With local version 2.6.2 the command completes in 1 or 2 seconds and
successfully creates foo2.txt with the same content.

With local version 2.6.3-pre{1,2} it downloads the whole file which takes
more than 1 minute due to bwlimit. It seems it doesn't notice there is already
a file with a similar name. In these cases the access time of local foo1.txt
is not changed which means the file wasn't open by rsync.

I tried the same with all these versions of rsync running on the server, but
the server side versions seemed to be irrelevant.

Configure bugmail: https://bugzilla.samba.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the rsync mailing list